On 06/07/2026 12:12, Oswald Buddenhagen wrote:
On Tue, Jun 30, 2026 at 04:29:00PM +0100, Phillip Wood wrote:
quoted
Rather than using an integer where -1 is an error, 0 is success and
1 means there were conflicts use an enum. This is clearer and lets
us add a separate return value for commits that are dropped because
they become empty in the next commit.
have you attempted widening the scope of the enum? the three conversions
between the new enum and existing int return values irk me.
I know what you mean, but how wide should be go? Using the enum just one
level up the call chain means converting a whole load of functions which
creates a lot of churn that someone needs to review. I decided to keep
the enum limited to this scope for now to avoid that.
Thanks
Phillip