Re: [PATCH v3 0/9] Implement `promisor.storeFields` and `--filter=auto`
From: Patrick Steinhardt <hidden>
Date: 2026-02-13 11:26:14
On Thu, Feb 12, 2026 at 11:08:31AM +0100, Christian Couder wrote:
Changes since v2
================
Thanks to Patrick Steinhardt, Jean-Noël Avila and Junio Hamano for
reviewing the previous version!
The patch series has been rebased on top of current 'master' at
864f55e190 (The second batch, 2026-02-09) to avoid a small conflict.
In patch 2/9, new checks have been added to the "clone with
promisor.storeFields=partialCloneFilter" test. We now check that a
subsequent fetch can update the configuration.
In patch 4/9, a small change has been made to the arguments of
`backfill_tags()` in "builtin/fetch.c" to fix a conflict with 'master'.
In patch 5/9, the commit message has been improved.
In patch 7/9, `captured_filters` has been renamed `accepted_filters`.
Patch 8/9 is new. It changes the signature of
`promisor_remote_reply()` and allows this function to not assemble a
reply string if this is not needed by the caller.
Patch 9/9, has a number of small changes in "fetch-pack.c":
- The call to `promisor_remote_reply()` is simplified a bit as it
doesn't require a reply string to be assembled.
- A comment has been reworded for clarity.
- The call to `gently_parse_list_objects_filter()` and the check to
error out in case it fails have been simplified.All of these changes look good to me, thanks! Patrick