Re: [PATCH] t9101: Refactor test_expect_success format
From: Seyi Chamber <hidden>
Date: 2024-11-01 07:51:27
On Thu, 31 Oct 2024 at 21:15, Taylor Blau [off-list ref] wrote:
On Thu, Oct 31, 2024 at 10:45:53AM +0100, Seyi Kuforiji wrote:quoted
The current script uses an outdated formatting style for test_expect_success blocks, where each argument is separated by a backslash and newline. This style can lead to readability issues and makes it harder to maintain the script. The modern style consolidates the multi-line command arguments into a single quoted block, whichStrange line wrapping?
That error probably occurred while I was editing the message. Should I edit and send an updated patch?
quoted
improves readability, maintainability, and aligns the code with current coding standards. Signed-off-by: Seyi Kuforiji <redacted> --- t/t9101-git-svn-props.sh | 48 ++++++++++++++++++++++------------------ 1 file changed, 26 insertions(+), 22 deletions(-)This does not apply cleanly on 'master', so I assume that you wanted it based on sk/t9101-cleanup. That's fine, but please let me know in the future in case it's every less obvious :-). The changes themselves all look quite sensible, though. Thanks, Taylor
Thanks, Taylor for pointing out this issue. I have rebased my change onto the latest master branch and resolved the conflicts for future updates. Thanks, Seyi