Re: [PATCH 3/3] compat/mingw: support POSIX semantics for atomic renames
From: Kristoffer Haugsbakk <hidden>
Date: 2024-10-24 07:18:40
From: Kristoffer Haugsbakk <hidden>
Date: 2024-10-24 07:18:40
On Thu, Oct 24, 2024, at 08:30, Patrick Steinhardt wrote:
quoted
s/FILE_RENAME_POSIX_SEMANICS/FILE_RENAME_FLAG_POSIX_SEMANTICS/No, this is actually intentional. There are two different flags: - FILE_RENAME_POSIX_SEMANTICS is what ntifs.h exposes and what I've been linking for documentation. This flag cannot be used though with `FileRenameInfoEx`. - FILE_RENAME_FLAG_POSIX_SEMANTICS is what needs to be used with `FileRenameInfoEx`, but it is undocumented.
I made a copy–paste mistake. :P I should have just pointed out this
(missing T):
_SEMANICS
So you wrote it the correct-looking way in your first bullet
point here.