Thread (14 messages) flat view 14 messages, 5 authors, 2021-10-01

ab/lib-subtest

From: Ævar Arnfjörð Bjarmason <hidden>
Date: 2021-10-01 15:07:47

On Thu, Sep 30 2021, Junio C Hamano wrote:
* ab/lib-subtest (2021-09-22) 9 commits
 - test-lib tests: get rid of copy/pasted mock test code
 - test-lib tests: assert 1 exit code, not non-zero
 - test-lib tests: refactor common part of check_sub_test_lib_test*()
 - test-lib tests: avoid subshell for "test_cmp" for readability
 - test-lib tests: don't provide a description for the sub-tests
 - test-lib tests: split up "write and run" into two functions
 - test-lib tests: move "run_sub_test" to a new lib-subtest.sh
 - Merge branch 'ps/t0000-output-directory-fix' into ab/lib-subtest
 - Merge branch 'jk/t0000-subtests-fix' into ab/lib-subtest

 Updates to the tests in t0000 to test the test framework.

 Will merge to 'next'?
I think it's ready, Carlo (CC'd) gave it a look and I re-rolled
addressing his feedback:
https://lore.kernel.org/git/cover-v4-0.7-00000000000-20210922T111734Z-avarab@gmail.com/ (local)

It's something I have some test-lib.sh UX improvements/simplification
waiting on, so having it go forward would be great :) Thanks!
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help