Re: [PATCH v2 2/8] builtin/checkout.c: complete parallel checkout support
From: Matheus Tavares Bernardino <hidden>
Date: 2021-05-03 14:21:47
On Sat, May 1, 2021 at 2:08 PM Christian Couder [off-list ref] wrote:
On Fri, Apr 30, 2021 at 11:40 PM Matheus Tavares [off-list ref] wrote:quoted
Pathspec-limited checkouts (like `git checkout *.txt`) are performed by a code path that doesn't yet support parallel checkout because it calls checkout_entry() directly, instead of unpack_trees(). Let's add parallel checkout support for this code path too. Note: the transient cache entries allocated in checkout_merged() are nows/Note: the/The/
Thanks
quoted
allocated in a mem_pool which is only discarded after parallel checkout finishes. This is done because the entries need to be valid when run_parallel_checkout() is called.quoted
-static int checkout_merged(int pos, const struct checkout *state, int *nr_checkouts) +static int checkout_merged(int pos, const struct checkout *state, + int *nr_checkouts, struct mem_pool *ce_mem_pool)For consistency with the previous patch, maybe: s/ce_mem_pool/ce_mp/
Yeah, I agree that it's a good idea to keep this consistent. In fact, instead of changing `ce_mem_pool` here, I think I should change `mp` in the previous patch to either `mem_pool` or `ce_mem_pool`. Those seem to be the most common names, at read-cache.c, for a memory pool struct holding cache entries.