Re: [PATCH v2 7/8] packfile: add kept-pack cache for find_kept_pack_entry()
From: Jeff King <hidden>
Date: 2021-02-17 20:26:29
On Wed, Feb 17, 2021 at 02:54:33PM -0500, Taylor Blau wrote:
quoted
OK, so we keep a single cache based on the flags, and then if somebody ever asks for different flags, we throw it away. That's probably OK for our purposes, since we wouldn't expect multiple callers within a single process. [...some alternatives]All interesting ideas. In this patch (and by the end of the series) callers that use the kept pack cache never ask for the cache with a different set of flags. IOW, there isn't a situation where a caller would populate the in-core kept pack cache, and then suddenly ask for both in-core and on-disk packs to be kept. So all of this code is defensive in case that were to change, and suddenly we'd be returning subtly wrong results. I could imagine that being kind of a nasty bug to track down, so detecting and invalidating the cache would make it a non-issue.
Yeah, I agree that the current crop of callers does not care. And I am
glad we are not leaving a booby-trap for later programmers with respect
to correctness (by virtue of the invalidation function). But it does
feel like we are leaving one for performance, which they very well might
not realize the cache is doing worse-than-nothing.
Would just doing:
if (cache.packs && cache.flags != flags)
BUG("kept-pack-cache cannot handle multiple queries in a single process");
be a better solution? That is not helping anyone towards a world where
we gracefully handle back-and-forth queries. But it makes it abundantly
clear when such a thing would become necessary.
quoted
Is there any reason not to just embed the kept_pack_cache struct inside the object_store? It's one less pointer to deal with. I wonder if this is a holdover from an attempt to have multiple caches. (I also think it would be reasonable if we wanted to hide the definition of the cache struct from callers, but we don't seem do to that).Not a holdover, just designed to avoid adding too many extra fields to the object-store. I don't feel strongly, but I do think hiding the definition is a good idea, so I'll inline it.
This response confuses me a bit. Hiding the definition from callers would mean _keeping_ it as a pointer, but putting the definition into packfile.c, where nobody outside that file could see it (at least that is what I meant by hiding). But inlining it to me implies embedding the struct (not a pointer to it) in "struct object_store", defining the struct at the point we define the struct field which uses it. I am fine with either, to be clear. I'm just confused which you are proposing to do. :) -Peff