Re: [RFC PATCH 02/10] submodule: factor out a config_gitmodules_set function
flat view
From: Stefan Beller <hidden>
Date: 2018-05-15 01:20:25
On Mon, May 14, 2018 at 3:58 AM, Antonio Ospite [off-list ref] wrote:
Introduce a new config_gitmodules_set function to write config values to the .gitmodules file. This is in preparation for a future change which will use the function to write to the .gitmodules file in a more controlled way instead of using "git config -f .gitmodules". Signed-off-by: Antonio Ospite <redacted> --- Not sure about the name, and maybe it can go in config.c for symmetry with config_from_gitmodules?
What is the function about (in the end state and now) ? is it more of a * configure_submodules_config() which would convey it is a generic function to configure submodules (i.e. it may not even write to *the* .gitmodules file but somewhere else, such as a helper ref) This doesn't sound like it as we make use of the function in update_path_in_gitmodules() that is used from git-mv, which would want to ensure that the specific .gitmodules file is changed. * gitmodules_file_set() that focuses on the specific file that we want to modify? * ... Let's continue reading the series to see the end state for a good name. Stefan