Re: [PATCH 7/7] config: flip return value of store_write_*()
From: Jeff King <hidden>
Date: 2017-09-15 00:46:43
On Wed, Sep 13, 2017 at 02:25:28PM -0700, Jonathan Nieder wrote:
quoted
Let's flip them to follow the usual write() conventions and update all callers. As these are local to config.c, it's unlikely that we'd have new callers in any topics in flight (which would be silently broken by our change). But just to be on the safe side, let's rename them to just write_section() and write_pairs(). That also accentuates their relationship with write(). Signed-off-by: Jeff King <redacted>The caller only cares if it succeeded, right? Could this return the customary 0 vs -1 instead of the number of bytes written?
Yes, it could. I went with "follow the conventions of write()" because these are used in a big chain of write() calls (well, really write_in_full). But given the current callers, it does not matter either way. Thanks for reviewing the series, and sorry if my comments have been a bit terse. I'm trying to clear my pile before going out of town for a few days (which I admit may have contributed to my desire for you to prepare patches on top). But either way, don't expect a re-roll until next week at the earliest. -Peff