Re: [RFC PATCH 01/10] pack: move pack name-related functions
From: Ben Peart <hidden>
Date: 2017-08-11 19:38:39
On 8/9/2017 1:16 PM, Jonathan Tan wrote:
On Wed, 9 Aug 2017 14:00:40 +0200 Christian Couder [off-list ref] wrote:quoted
On Tue, Aug 8, 2017 at 10:50 PM, Jonathan Tan [off-list ref] wrote:quoted
On Tue, 8 Aug 2017 13:36:24 -0700 Stefan Beller [off-list ref] wrote:quoted
There are also packed refs, so one could (like I did) think that pack.c is for generic packing of things, maybe packfile.c would be more clear?Good point. I'll use packfile.c and packfile.h in the next version.It looks like you used "packfile.c" and "pack.h" in v2. Is there a reason why it's not using "packfile.h"?Ah, I forgot to mention this in the cover letter. I thought that one header was sufficient to cover all pack-related things, so if we wanted to know which files used pack-related things, we would only need to search for one string instead of two. Also, the division between "pack.h" and the hypothetical "packfile.h" was not so clear to me.
I prefer having source and the header files that export the functions have matching names to make it easy to find them. I would prefer packfile.h vs pack.h myself.