Re: [PATCH 13/16] submodule: teach unpack_trees() to update submodules
From: Stefan Beller <hidden>
Date: 2016-11-18 23:39:08
From: Stefan Beller <hidden>
Date: 2016-11-18 23:39:08
On Tue, Nov 15, 2016 at 4:25 PM, Brandon Williams [off-list ref] wrote:
On 11/15, Stefan Beller wrote:quoted
+ int flags = CE_MATCH_IGNORE_VALID|CE_MATCH_IGNORE_SKIP_WORKTREE;For readability you may want to have spaces between the two flags
done
quoted
+ if (o->index_only + || (!((old->ce_flags & CE_VALID) || ce_skip_worktree(old)) + && (o->reset || ce_uptodate(old)))) + return 0;The coding guidelines say that git prefers to have the logical operators on the right side like this:
fixed all the coding style issues.