Thread (46 messages) flat view 46 messages, 3 authors, 2016-10-06

Re: [PATCH v8 01/11] pkt-line: rename packet_write() to packet_write_fmt()

From: Jakub Narębski <hidden>
Date: 2016-09-24 21:15:04

Hello Lars,

W dniu 20.09.2016 o 21:02, larsxschneider@gmail.com pisze:
From: Lars Schneider <redacted>

packet_write() should be called packet_write_fmt() as the string
parameter can be formatted.
I would say:

  packet_write() should be called packet_write_fmt() because it
  is printf-like function where first parameter is format string.
  
Or something like that.  But such minor change might be not worth
yet another reroll of this patch series.

Perhaps it would be a good idea to explain the reasoning behind
this change:

  This is important distinction to know from the name if the
  function accepts arbitrary binary data and/or arbitrary
  strings to be written - packet_write[_fmt()] do not.
Suggested-by: Junio C Hamano <redacted>
Just so nobody wonders later why this patch was needed/suggested.
Signed-off-by: Lars Schneider <redacted>
---
 builtin/archive.c        |  4 ++--
 builtin/receive-pack.c   |  4 ++--
 builtin/remote-ext.c     |  4 ++--
 builtin/upload-archive.c |  4 ++--
 connect.c                |  2 +-
 daemon.c                 |  2 +-
 http-backend.c           |  2 +-
 pkt-line.c               |  2 +-
The header of the renamed function looks now very nice:

 void packet_write_fmt(int fd, const char *fmt, ...)
                   ^^^                     ^^^
 pkt-line.h               |  2 +-
 shallow.c                |  2 +-
 upload-pack.c            | 30 +++++++++++++++---------------
 11 files changed, 29 insertions(+), 29 deletions(-)
Diffstat looks correct.  Was the patch generated by doing search
and replace?

Best,
-- 
Jakub Narębski
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help