On Thu, 14 Dec 2006, Johannes Schindelin wrote:
Hi,
On Wed, 13 Dec 2006, Junio C Hamano wrote:
quoted
We might want to add a pair of built-in internal aliases though:
[alias]
cat = cat-file -p
less = -p cat-file -p
or have these as samples in template .git/config file.
I sent a patch which makes "git show" have that functionality, and
frankly, I disagree "less" would be a good name for it. It uses the
_pager_, which is not always "less", and besides, what it does is to show
that particular blob. So obviously, I think my patch is the best approach.
I think your approach is pretty sensible too.