Hi,
On Wed, 13 Dec 2006, Junio C Hamano wrote:
Andy Parkins [off-list ref] writes:
quoted
* git-cat-file is badly named. git-cat-object would be slightly
better.
Not a Porcelain.
We might want to add a pair of built-in internal aliases though:
[alias]
cat = cat-file -p
less = -p cat-file -p
or have these as samples in template .git/config file.
I sent a patch which makes "git show" have that functionality, and
frankly, I disagree "less" would be a good name for it. It uses the
_pager_, which is not always "less", and besides, what it does is to show
that particular blob. So obviously, I think my patch is the best approach.
BTW if you now say "git show master:README" it will show _nothing_, not
even an error message.
Ciao,