On Thu, Aug 04, 2016 at 12:00:31AM +0200, Michael Haggerty wrote:
Rename i to end, and alternate between using start and end as the
indexing variable as appropriate.
Rename ixref to end_matching_other.
Add some more comments.
I'd usually complain that there is too much "what" in your commit
message, but in this case, the diff really is hard to read. Having a
summary up front is nice.
There's no "why", but I imagine it is just "I had to do this to even
make sense of this function".
-Peff