Thread (7 messages) flat view 7 messages, 3 authors, 2016-06-15

Re: [PATCH] Define constants for lengths of object names

From: Jonathan Nieder <hidden>
Date: 2016-06-15 23:00:57

Hi,

brian m. carlson wrote:
quoted hunk ↗ jump to hunk
--- a/object.h
+++ b/object.h
[...]
quoted hunk ↗ jump to hunk
@@ -49,7 +56,7 @@ struct object {
 	unsigned used : 1;
 	unsigned type : TYPE_BITS;
 	unsigned flags : FLAG_BITS;
-	unsigned char sha1[20];
+	unsigned char sha1[GIT_OID_RAWSZ];
Maybe my brain has been damaged by reading code from too many C
projects that hard-code some constants, but I find '20' easier to read
here.

What happened to the

	struct object_id {
		unsigned char id[20];
	};

	...

	struct object {
		...
		struct object_id id;
	};

idea?

Thanks,
Jonathan
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help