[PATCH] Define constants for lengths of object names

Subsystems: the rest

STALE3726d

7 messages, 3 authors, 2016-06-15 · open the first message on its own page

[PATCH] Define constants for lengths of object names

From: brian m. carlson <hidden>
Date: 2016-06-15 23:00:57

Using preprocessor constants rather than hardcoded numbers is considered a
good programming practice.  Provide two constants, GIT_OID_RAWSZ and
GIT_OID_HEXSZ, which are the lengths of an SHA-1 object name in bytes and
hex digits, respectively.  These names are the same as those used by
libgit2.

Signed-off-by: brian m. carlson <redacted>
---
 object.h | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)
diff --git a/object.h b/object.h
index 6e12f2c..f1cff2d 100644
--- a/object.h
+++ b/object.h
@@ -1,6 +1,13 @@
 #ifndef OBJECT_H
 #define OBJECT_H
 
+/*
+ * The length in bytes and in hex digits of an object name (SHA-1 value).
+ * These are the same names used by libgit2.
+ */
+#define GIT_OID_RAWSZ 20
+#define GIT_OID_HEXSZ 40
+
 struct object_list {
 	struct object *item;
 	struct object_list *next;
@@ -49,7 +56,7 @@ struct object {
 	unsigned used : 1;
 	unsigned type : TYPE_BITS;
 	unsigned flags : FLAG_BITS;
-	unsigned char sha1[20];
+	unsigned char sha1[GIT_OID_RAWSZ];
 };
 
 extern const char *typename(unsigned int type);
-- 
2.0.0.rc0

Re: [PATCH] Define constants for lengths of object names

From: Jonathan Nieder <hidden>
Date: 2016-06-15 23:00:57

Hi,

brian m. carlson wrote:
quoted hunk
--- a/object.h
+++ b/object.h
[...]
quoted hunk
@@ -49,7 +56,7 @@ struct object {
 	unsigned used : 1;
 	unsigned type : TYPE_BITS;
 	unsigned flags : FLAG_BITS;
-	unsigned char sha1[20];
+	unsigned char sha1[GIT_OID_RAWSZ];
Maybe my brain has been damaged by reading code from too many C
projects that hard-code some constants, but I find '20' easier to read
here.

What happened to the

	struct object_id {
		unsigned char id[20];
	};

	...

	struct object {
		...
		struct object_id id;
	};

idea?

Thanks,
Jonathan

Re: [PATCH] Define constants for lengths of object names

From: Jonathan Nieder <hidden>
Date: 2016-06-15 23:00:57

Jonathan Nieder wrote:
brian m. carlson wrote:
quoted
--- a/object.h
+++ b/object.h
[...]
quoted
@@ -49,7 +56,7 @@ struct object {
 	unsigned used : 1;
 	unsigned type : TYPE_BITS;
 	unsigned flags : FLAG_BITS;
-	unsigned char sha1[20];
+	unsigned char sha1[GIT_OID_RAWSZ];
Maybe my brain has been damaged by reading code from too many C
projects that hard-code some constants, but I find '20' easier to read
here.
That said, RAW_SHA1_BYTES would sound okay to me.

Part of the problem was how long it takes to mentally parse oid_rawsz.

Thanks,
Jonathan

Re: [PATCH] Define constants for lengths of object names

From: brian m. carlson <hidden>
Date: 2016-06-15 23:00:58

On Thu, May 01, 2014 at 10:20:07AM -0700, Jonathan Nieder wrote:
Hi,

brian m. carlson wrote:
quoted
--- a/object.h
+++ b/object.h
[...]
quoted
@@ -49,7 +56,7 @@ struct object {
 	unsigned used : 1;
 	unsigned type : TYPE_BITS;
 	unsigned flags : FLAG_BITS;
-	unsigned char sha1[20];
+	unsigned char sha1[GIT_OID_RAWSZ];
Maybe my brain has been damaged by reading code from too many C
projects that hard-code some constants, but I find '20' easier to read
here.

What happened to the

	struct object_id {
		unsigned char id[20];
	};

	...

	struct object {
		...
		struct object_id id;
	};

idea?
There didn't seem to be a huge amount of support for it.  Also, there
were concerns that some architectures might impose alignment constraints
on it that made sizeof(struct object_id) != 20.

-- 
brian m. carlson / brian with sandals: Houston, Texas, US
+1 832 623 2791 | http://www.crustytoothpaste.net/~bmc | My opinion only
OpenPGP: RSA v4 4096b: 88AC E9B2 9196 305B A994 7552 F1BA 225C 0223 B187

Re: [PATCH] Define constants for lengths of object names

From: Jonathan Nieder <hidden>
Date: 2016-06-15 23:00:58

brian m. carlson wrote:
On Thu, May 01, 2014 at 10:20:07AM -0700, Jonathan Nieder wrote:
quoted
What happened to the

	struct object_id {
		unsigned char id[20];
	};

	...

	struct object {
		...
		struct object_id id;
	};

idea?
There didn't seem to be a huge amount of support for it.
I can make up for it in enthuasiasm.  Please?  It's something I've
wanted for a long time but never found the time to do.
                                                          Also, there
were concerns that some architectures might impose alignment constraints
on it that made sizeof(struct object_id) != 20.
Sounds awful.  What architecture?

Thanks,
Jonathan

Re: [PATCH] Define constants for lengths of object names

From: Duy Nguyen <hidden>
Date: 2016-06-15 23:00:58

On Fri, May 2, 2014 at 6:05 AM, Jonathan Nieder [off-list ref] wrote:
brian m. carlson wrote:
quoted
On Thu, May 01, 2014 at 10:20:07AM -0700, Jonathan Nieder wrote:
quoted
quoted
What happened to the

     struct object_id {
             unsigned char id[20];
     };

     ...

     struct object {
             ...
             struct object_id id;
     };

idea?
There didn't seem to be a huge amount of support for it.
I can make up for it in enthuasiasm.  Please?  It's something I've
wanted for a long time but never found the time to do.
It's definitely better in the sense that the compiler will catch new
"char[20]" declarations for us. It's also a lot more work.
quoted
                                                          Also, there
were concerns that some architectures might impose alignment constraints
on it that made sizeof(struct object_id) != 20.
Sounds awful.  What architecture?
No architecture was named last time if I remember correctly. But we
could check "sizeof(struct object_id) == 20" in a test or something.
When people scream, we can pack the struct on that particular
platform?
-- 
Duy

Re: [PATCH] Define constants for lengths of object names

From: brian m. carlson <hidden>
Date: 2016-06-15 23:00:59

On Fri, May 02, 2014 at 07:15:44AM +0700, Duy Nguyen wrote:
On Fri, May 2, 2014 at 6:05 AM, Jonathan Nieder [off-list ref] wrote:
quoted
I can make up for it in enthuasiasm.  Please?  It's something I've
wanted for a long time but never found the time to do.
It's definitely better in the sense that the compiler will catch new
"char[20]" declarations for us. It's also a lot more work.
It is.  I'm going to start with a patch that introduces struct object_id
and the fixed constants.  Then I'm going to get a patch that compiles
with lots of warnings, and then I'm going to fix all those warnings.
Otherwise, the patch will simply be too enormous to review.

I'm willing to hear other suggestions for going about this, though.
No architecture was named last time if I remember correctly. But we
could check "sizeof(struct object_id) == 20" in a test or something.
When people scream, we can pack the struct on that particular
platform?
Sounds like a plan.  I am not aware of any architecture that has this
limitation; I've worked with x86(-64)?, 32-bit PowerPC, UltraSPARC, and
ARM.

-- 
brian m. carlson / brian with sandals: Houston, Texas, US
+1 832 623 2791 | http://www.crustytoothpaste.net/~bmc | My opinion only
OpenPGP: RSA v4 4096b: 88AC E9B2 9196 305B A994 7552 F1BA 225C 0223 B187
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help