Re: [PATCH v2 1/3][GSOC] diff: rename read_directory() to get_path_list()
From: Eric Sunshine <hidden>
Date: 2016-06-15 23:00:23
On Wed, Mar 19, 2014 at 7:23 AM, Hiroyuki Sano [off-list ref] wrote:
Subject: diff: rename read_directory() to get_path_list()
You probably mean 'diff-no-index' here rather than 'diff'.
Including "dir.h" in "diff-no-index.c", it causes a compile error, because the same name function read_directory() is declared globally in "dir.h".
It might be a bit clearer to give a hint as to why dir.h will be a problem:
A subsequent patch will include dir.h in diff-no-index.c,
however, dir.h declares a read_directory() which is different
from the one defined statically by diff-no-index.c.
This change is to avoid conflicts as above.
Good explanation, but write in imperative mood:
Rename the local read_directory() to avoid the conflict.
quoted hunk ↗ jump to hunk
Signed-off-by: Hiroyuki Sano <redacted> --- diff-no-index.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-)diff --git a/diff-no-index.c b/diff-no-index.c index 8e10bff..20b6a8a 100644 --- a/diff-no-index.c +++ b/diff-no-index.c@@ -16,7 +16,7 @@ #include "builtin.h" #include "string-list.h" -static int read_directory(const char *path, struct string_list *list) +static int get_path_list(const char *path, struct string_list *list) { DIR *dir; struct dirent *e;@@ -107,9 +107,9 @@ static int queue_diff(struct diff_options *o, int i1, i2, ret = 0; size_t len1 = 0, len2 = 0; - if (name1 && read_directory(name1, &p1)) + if (name1 && get_path_list(name1, &p1)) return -1; - if (name2 && read_directory(name2, &p2)) { + if (name2 && get_path_list(name2, &p2)) { string_list_clear(&p1, 0); return -1; } --1.9.0