Thread (21 messages) flat view 21 messages, 5 authors, 2016-06-15

RE: [PATCH 1/2] sequencer: trivial fix

From: Joachim Schmitz <hidden>
Date: 2016-06-15 22:57:29

From: Felipe Contreras [mailto:felipe.contreras@gmail.com]
Sent: Wednesday, May 29, 2013 1:24 PM
To: Joachim Schmitz
Cc: git@vger.kernel.org
Subject: Re: [PATCH 1/2] sequencer: trivial fix

On Wed, May 29, 2013 at 6:13 AM, Joachim Schmitz
[off-list ref] wrote:
quoted
quoted
From: Felipe Contreras [mailto:felipe.contreras@gmail.com]
Sent: Wednesday, May 29, 2013 12:52 PM
To: Joachim Schmitz
Cc: git@vger.kernel.org
Subject: Re: [PATCH 1/2] sequencer: trivial fix

On Wed, May 29, 2013 at 4:58 AM, Joachim Schmitz
[off-list ref] wrote:
quoted
Felipe Contreras wrote:
quoted
Junio C Hamano wrote:
quoted
quoted
quoted
It probably is better to fold this patch into the other one when it
is rerolled to correct the option name gotcha "on the tin".

Why? This patch is standalone and fixes an issue that is independent
of the other patch. Why squash two patches that do *two* different
things?

Anyway, I'll happily drop this patch if you want this memory leak to
remain. But then I'll do the same in the other patch.

This mantra of avodiing 'goto' is not helping anybody.

adding 5 letters (to change the next "if" into an "else if") versus your
addition of several lines and some 15 additional letters (ignoring the
whitsspace)  is IMHO enough to see what is better?
This has nothing to do with what Junio said.
Well, it has, but you had snipped it. But replied to the goto issue regardless
I didn't snip anything, this is a different context.
You did in your reply to me
quoted
quoted
This is better done without "goto" in general.
He din't say:
__
It probably is better to fold this patch into the other one when it
is rerolled to correct the option name gotcha "on the tin", AND you
fix the goto issue.
__

You added that last part in your mind. Moreover, he didn't say goto
was an issue, he simply stated an opinion about some generality.
I added nothing in my mind, I just copy/paste that statement and was commenting on that and only that.
At least intended to.

Whenever anybody added more else branches, that's the time to possible switch to the goto style.

And for the record: I agree with you that these 2 things should rather not be in a single patch as they are completely unrelated.

Bye, Jojo
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help