Hi,
On Sun, Apr 15, 2012 at 04:37:18PM -0500, Jonathan Nieder wrote:
Felipe Contreras wrote:
quoted
This simplifies the completions, and makes it easier to define aliases:
git_complete gf git_fetch
Sounds neat. Unfortunately users could already be using a function
with some other purpose named git_complete in their .profile and this
would override it. The completion script has so far stuck to a
limited namespace:
_git_* (completion functions)
__git_* (everything else, including public interfaces like __git_ps1)
Don't forget the oddball __gitdir() function ;)
A name like __git_complete should work, presumably.
And foo_wrap() should also fit into those namespaces.
Best,
Gábor