On Thu, Feb 2, 2012 at 10:16 PM, Jonathan Nieder [off-list ref] wrote:
Dmitry Ivankov wrote:
quoted
On Thu, Feb 2, 2012 at 4:59 PM, Jonathan Nieder [off-list ref] wrote:
quoted
quoted
From: Ramsay Jones <redacted>
Code using the argument names a and b just doesn't look right (not
sure why!). Use more explicit names "offset" and "len" to make their
type and function clearer.
Well, it's still not clear. Given off_t a, size_t b, check that a+b
fits into type... which type?
"offset" and "length" don't imply that it's "type of offset" or maybe
"type of length".
Hmm... in vector arithmetic, position (i.e., file offset) + displacement
(i.e., size of chunk) = position (i.e., new file offset). Any ideas
for making this clearer?
Maybe rename to check_offset_overflow to make it explicit?
--
David Barr