Thread (10 messages) flat view 10 messages, 5 authors, 2016-06-15

Re: [PATCH 1/3] vcs-svn: rename check_overflow arguments for clarity

From: Dmitry Ivankov <hidden>
Date: 2016-06-15 22:52:55

Possibly related (same subject, not in this thread)

Hi

On Thu, Feb 2, 2012 at 4:59 PM, Jonathan Nieder [off-list ref] wrote:
From: Ramsay Jones <redacted>

Code using the argument names a and b just doesn't look right (not
sure why!).  Use more explicit names "offset" and "len" to make their
type and function clearer.
Well, it's still not clear. Given off_t a, size_t b, check that a+b
fits into type... which type?
"offset" and "length" don't imply that it's "type of offset" or maybe
"type of length".
quoted hunk ↗ jump to hunk
Signed-off-by: Jonathan Nieder <redacted>
---
Split out from Ramsay's patch.

 vcs-svn/sliding_window.c |   10 +++++-----
 1 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/vcs-svn/sliding_window.c b/vcs-svn/sliding_window.c
index 1bac7a4c..fafa4a63 100644
--- a/vcs-svn/sliding_window.c
+++ b/vcs-svn/sliding_window.c
@@ -31,15 +31,15 @@ static int read_to_fill_or_whine(struct line_buffer *file,
       return 0;
 }

-static int check_overflow(off_t a, size_t b)
+static int check_overflow(off_t offset, size_t len)
 {
-       if (b > maximum_signed_value_of_type(off_t))
+       if (len > maximum_signed_value_of_type(off_t))
               return error("unrepresentable length in delta: "
-                               "%"PRIuMAX" > OFF_MAX", (uintmax_t) b);
+                               "%"PRIuMAX" > OFF_MAX", (uintmax_t) len);
-       if (signed_add_overflows(a, (off_t) b))
+       if (signed_add_overflows(offset, (off_t) len))
               return error("unrepresentable offset in delta: "
                               "%"PRIuMAX" + %"PRIuMAX" > OFF_MAX",
-                               (uintmax_t) a, (uintmax_t) b);
+                               (uintmax_t) offset, (uintmax_t) len);
       return 0;
 }

--
1.7.9
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help