Ramkumar Ramachandra wrote:
Thanks for the elaborate explanation; I can see what's wrong with it
now. However, I "start_or_continue_or_stop_or_[insert more options
here]_replay" isn't a good name. I want something future-proof,
because I intend to extend this with more nifty helpers like "skip
one". Your earlier "pick_revisions" suggestion doesn't sound like a
bad alternative now -- let me know if you have any other suggestions.
Sounds like sensible reasoning. You are free to choose a name; I just
wanted to make sure the effect of that name is clear.
If I were doing it, I would let the API include multiple entry points,
one for each operation ("start", "abort", "skip one", etc).
Side note: I believe a previous patch had a justification of allowing
for multiple entry points, which I had thought was preparation for
this. It is possible that that patch some other intended positive
effects, too, though.