[PATCH 04/10] revert: Rename no_replay to record_origin
From: Ramkumar Ramachandra <hidden>
Date: 2016-06-15 22:51:19
Subsystem:
the rest · Maintainer:
Linus Torvalds
Give the variable "no_replay" a new name "record_origin", so that there is no confusion when a "replay" structure is introduced later in the series. Suggested-by: Jonathan Nieder <redacted> Signed-off-by: Ramkumar Ramachandra <redacted> --- builtin/revert.c | 8 ++++---- 1 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/builtin/revert.c b/builtin/revert.c
index 6c485f6..c48a7df 100644
--- a/builtin/revert.c
+++ b/builtin/revert.c@@ -35,7 +35,7 @@ static const char * const cherry_pick_usage[] = { NULL }; -static int edit, no_replay, no_commit, mainline, signoff, allow_ff; +static int edit, record_origin, no_commit, mainline, signoff, allow_ff; static enum { REVERT, CHERRY_PICK } action; static int commit_argc; static const char **commit_argv;
@@ -90,7 +90,7 @@ static void parse_args(int argc, const char **argv) if (action == CHERRY_PICK) { struct option cp_extra[] = { - OPT_BOOLEAN('x', NULL, &no_replay, "append commit name"), + OPT_BOOLEAN('x', NULL, &record_origin, "append commit name"), OPT_BOOLEAN(0, "ff", &allow_ff, "allow fast-forward"), OPT_END(), };
@@ -467,7 +467,7 @@ static int do_pick_commit(struct commit *commit) next = commit; next_label = msg.label; add_message_to_msg(commit_sha1_hex, &msgbuf, msg.message); - if (no_replay) { + if (record_origin) { strbuf_addstr(&msgbuf, "(cherry picked from commit "); strbuf_addstr(&msgbuf, sha1_to_hex(commit->object.sha1)); strbuf_addstr(&msgbuf, ")\n");
@@ -563,7 +563,7 @@ static int revert_or_cherry_pick(int argc, const char **argv) die(_("cherry-pick --ff cannot be used with --signoff")); if (no_commit) die(_("cherry-pick --ff cannot be used with --no-commit")); - if (no_replay) + if (record_origin) die(_("cherry-pick --ff cannot be used with -x")); if (edit) die(_("cherry-pick --ff cannot be used with --edit"));
--
1.7.5.GIT