Hi,
Error handling is a very complex topic, and trying to build it up with
the Sequencer series had disasterous consequences, as seen in the
previous iteration of the series. In this iteration, I've nearly
re-written everything from scratch, and tried to get the basics right,
without introducing anything new. Time is short, and I'll have to
work very hard if I want to target "master",
I hope there are no major issues with this iteration.
Thanks for reading.
-- Ram
Ramkumar Ramachandra (10):
advice: Introduce error_resolve_conflict
revert: Propogate errors upwards from do_pick_commit
revert: Eliminate global "commit" variable
revert: Rename no_replay to record_origin
revert: Introduce struct to keep command-line options
revert: Separate cmdline parsing from functional code
revert: Catch incompatible command-line options early
revert: Introduce HEAD, TODO files to persist state, plan
revert: Implement parsing --continue, --abort and --skip
revert: Implement --abort processing
advice.c | 17 ++-
advice.h | 1 +
builtin/revert.c | 484 +++++++++++++++++++++++++++++++++++++++---------------
3 files changed, 361 insertions(+), 141 deletions(-)
--
1.7.5.GIT