Thread (7 messages) flat view 7 messages, 4 authors, 2016-06-15

Re: [PATCH v5 2/4] Introduce "double conversion during merge" more gradually

From: Eyvind Bernhardsen <hidden>
Date: 2016-06-15 22:49:04

On 1. juli 2010, at 22.15, Jakub Narebski wrote:
Finn Arne Gangstad [off-list ref] writes:
quoted
On Thu, Jul 01, 2010 at 10:05:17AM -0700, Jakub Narebski wrote:
quoted
What about `merge.renormalize' ;-) ?
Best so far! Or what about "merge.canonicalize"? Sorry for bikeshedding :)
Perhaps `merge.regularize'?  Or `merge.normalizeToWorkTree'?
It is about converting to worktree version according to current
settings, IIUC...
Almost, it's about converting to the _repository_ version according to current (that is, merged) settings.  Since the content is already in repository format it needs to be converted to the worktree version before it is converted back, hence Junio's "doubleConvert".

"merge.renormalizeUsingMergedGitattributes"?
-- 
Eyvind
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help