On 1. juli 2010, at 18:25, Junio C Hamano [off-list ref] wrote:
Johannes Sixt [off-list ref] writes:
quoted
Am 7/1/2010 11:09, schrieb Eyvind Bernhardsen:
quoted
+core.mergePrefilter::
BTW, any particular reason that this is in the core namespace rather than
merge namespace? It could be merge.prefilter.
Good point.
Somehow to me "prefilter" does not sound to convey what really is going on
here, though.
"Doubleconvert" doesn't really mean anything either though, and "convert" and "normalise" are too generic. I think the problem is that there's no existing name for what convert.c does.
I chose "filter" because of the filter property; the crlf and ident things can be regarded as built-in filters.
--
Eyvind
From: Jakub Narebski <hidden> Date: 2016-06-15 22:49:04
Eyvind Bernhardsen [off-list ref] writes:
On 1. juli 2010, at 18:25, Junio C Hamano [off-list ref] wrote:
quoted
Johannes Sixt [off-list ref] writes:
quoted
Am 7/1/2010 11:09, schrieb Eyvind Bernhardsen:
quoted
+core.mergePrefilter::
BTW, any particular reason that this is in the core namespace rather than
merge namespace? It could be merge.prefilter.
Good point.
Somehow to me "prefilter" does not sound to convey what really is going on
here, though.
"Doubleconvert" doesn't really mean anything either though, and
"convert" and "normalise" are too generic. I think the problem is
that there's no existing name for what convert.c does.
I chose "filter" because of the filter property; the crlf and ident
things can be regarded as built-in filters. -- Eyvind
What about `merge.renormalize' ;-) ?
--
Jakub Narebski
Poland
ShadeHawk on #git
From: Finn Arne Gangstad <hidden> Date: 2016-06-15 22:49:04
On Thu, Jul 01, 2010 at 10:05:17AM -0700, Jakub Narebski wrote:
Eyvind Bernhardsen [off-list ref] writes:
quoted
On 1. juli 2010, at 18:25, Junio C Hamano [off-list ref] wrote:
quoted
Johannes Sixt [off-list ref] writes:
quoted
Am 7/1/2010 11:09, schrieb Eyvind Bernhardsen:
quoted
+core.mergePrefilter::
[...]
quoted
quoted
Somehow to me "prefilter" does not sound to convey what really is going on
here, though.
"Doubleconvert" doesn't really mean anything either though, and
"convert" and "normalise" are too generic. I think the problem is
that there's no existing name for what convert.c does.
I chose "filter" because of the filter property; the crlf and ident
things can be regarded as built-in filters. -- Eyvind
What about `merge.renormalize' ;-) ?
Best so far! Or what about "merge.canonicalize"? Sorry for bikeshedding :)
- Finn Arne
On 1. juli 2010, at 18:25, Junio C Hamano [off-list ref] wrote:
quoted
Somehow to me "prefilter" does not sound to convey what really is going on
here, though.
"Doubleconvert" doesn't really mean anything either though, and
"convert" and "normalise" are too generic. I think the problem is
that there's no existing name for what convert.c does.
I chose "filter" because of the filter property; the crlf and ident
things can be regarded as built-in filters. -- Eyvind
What about `merge.renormalize' ;-) ?
I like it, but it's still a bit generic. "merge.renormalizeContent", perhaps?
--
Eyvind
From: Jakub Narebski <hidden> Date: 2016-06-15 22:49:04
Finn Arne Gangstad [off-list ref] writes:
On Thu, Jul 01, 2010 at 10:05:17AM -0700, Jakub Narebski wrote:
quoted
Eyvind Bernhardsen [off-list ref] writes:
quoted
On 1. juli 2010, at 18:25, Junio C Hamano [off-list ref] wrote:
quoted
Johannes Sixt [off-list ref] writes:
quoted
Am 7/1/2010 11:09, schrieb Eyvind Bernhardsen:
quoted
+core.mergePrefilter::
[...]
quoted
quoted
Somehow to me "prefilter" does not sound to convey what really is going on
here, though.
"Doubleconvert" doesn't really mean anything either though, and
"convert" and "normalise" are too generic. I think the problem is
that there's no existing name for what convert.c does.
I chose "filter" because of the filter property; the crlf and ident
things can be regarded as built-in filters. -- Eyvind
What about `merge.renormalize' ;-) ?
Best so far! Or what about "merge.canonicalize"? Sorry for bikeshedding :)
Perhaps `merge.regularize'? Or `merge.normalizeToWorkTree'?
It is about converting to worktree version according to current
settings, IIUC...
--
Jakub Narebski
Poland
ShadeHawk on #git
On Thu, Jul 01, 2010 at 10:05:17AM -0700, Jakub Narebski wrote:
quoted
What about `merge.renormalize' ;-) ?
Best so far! Or what about "merge.canonicalize"? Sorry for bikeshedding :)
Perhaps `merge.regularize'? Or `merge.normalizeToWorkTree'?
It is about converting to worktree version according to current
settings, IIUC...
Almost, it's about converting to the _repository_ version according to current (that is, merged) settings. Since the content is already in repository format it needs to be converted to the worktree version before it is converted back, hence Junio's "doubleConvert".
"merge.renormalizeUsingMergedGitattributes"?
--
Eyvind