[PATCH v3 0/4] Refactoring: remove duplicated code
From: Michael Lukashov <hidden>
Date: 2016-06-15 22:48:17
Hi,
Here is 3rd iteration of my refactoring patches. These patches take into
account suggestions made by Tay Ray Chuan, Johannes Sixt, Jeff King and Junio C Hamano
Michael Lukashov (4):
Refactoring: remove duplicated code from builtin-send-pack.c and
transport.c
Refactoring: connect.c: move duplicated code to a new function
'get_host_and_port'
Refactoring: move duplicated code from builtin-pack-objects.c and
fast-import.c to sha1_file.c
Refactoring: move duplicated code from builtin-checkout.c and
merge-recursive.c to xdiff-interface.c
builtin-checkout.c | 24 +-----
builtin-fetch.c | 20 +++---
builtin-pack-objects.c | 31 +-------
builtin-send-pack.c | 191 ++----------------------------------------------
cache.h | 8 ++
connect.c | 83 +++++++--------------
fast-import.c | 29 +-------
merge-recursive.c | 23 +-----
sha1_file.c | 20 +++++
transport.c | 22 +++---
transport.h | 11 +++
xdiff-interface.c | 17 ++++
xdiff-interface.h | 1 +
13 files changed, 123 insertions(+), 357 deletions(-)