Hi,
On Mon, 10 Aug 2009, Junio C Hamano wrote:
Nguyen Thai Ngoc Duy [off-list ref] writes:
quoted
quoted
Hmm. I understand that the assumption is that memset(&opts, 0,
sizeof(opts)); should give you a sensible default, but I cannot avoid
noticing that "no_sparse_hook = 0" is a double negation, something to be
avoided...
skip_sparse_hook then? :-)
It nicely avoids the double negation, indeed.
Why not making the hook to be skipped by default, and pass an explicit
option to trigger the hook?
I like Dscho's other suggestion to use patterns like .gitignore instead
of using hook scripts that needs to be ported across platforms, by the
way.
I forgot to mention that I checked dir.c to verify that
add_excludes_from_file_1() (which is static, so you'll either need to use
it in the same file, or even better, export it renaming it to something
like add_excludes_from_file_to_list()) and excluded_1() (same here)
already do a large part of what you need.
Ciao,
Dscho