Thread (4 messages) flat view 4 messages, 4 authors, 2016-06-15

Re: [PATCH 2/3] parse-options: add PARSE_OPT_CUSTOM_ARGH for complicated argh's

From: Jakub Narebski <hidden>
Date: 2016-06-15 22:46:47

Stephen Boyd [off-list ref] writes:
Junio C Hamano wrote:
quoted
You are asking a wrong person.  I am terrible at naming things; think
"rerere" ;-).

But I think custom-arghelp is much better than multargs.  You are asking
"use this help for argument value _literally_", so another possibility
perhaps is PARSE_OPT_ARGHELP_LITERAL.

After all, there probably are many other valid reasons why you may not
want "s/.*/<&>/" blindly applied to your string.  One reason may be
because the string describes multiple arguments, but I suspect that it is
not the only one.  It is better to name the option after what it does,
than naming it after one sample reason why you might want to use that
option.
Ok. I think PARSE_OPT_LITERAL_ARGH might be good; until someone comes up
with a better one of course.
Well, 'ARGH' sounds a bit strange. I think I'd prefer ARGHELP. :-)
-- 
Jakub Narebski
Poland
ShadeHawk on #git
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help