Stephen Boyd [off-list ref] writes:
This description sounds nice ;) Is PARSE_OPT_CUSTOM_ARGH a good name? I
was thinking maybe PARSE_OPT_MULTARGS is better?
You are asking a wrong person. I am terrible at naming things; think
"rerere" ;-).
But I think custom-arghelp is much better than multargs. You are asking
"use this help for argument value _literally_", so another possibility
perhaps is PARSE_OPT_ARGHELP_LITERAL.
After all, there probably are many other valid reasons why you may not
want "s/.*/<&>/" blindly applied to your string. One reason may be
because the string describes multiple arguments, but I suspect that it is
not the only one. It is better to name the option after what it does,
than naming it after one sample reason why you might want to use that
option.
quoted
Please update Documentation/technical/api-parse-options.txt as well.
There's no documentation on the flags yet, but I suppose I could add that.
Thanks.
Junio C Hamano wrote:
You are asking a wrong person. I am terrible at naming things; think
"rerere" ;-).
But I think custom-arghelp is much better than multargs. You are asking
"use this help for argument value _literally_", so another possibility
perhaps is PARSE_OPT_ARGHELP_LITERAL.
After all, there probably are many other valid reasons why you may not
want "s/.*/<&>/" blindly applied to your string. One reason may be
because the string describes multiple arguments, but I suspect that it is
not the only one. It is better to name the option after what it does,
than naming it after one sample reason why you might want to use that
option.
Ok. I think PARSE_OPT_LITERAL_ARGH might be good; until someone comes up
with a better one of course.
Stephen Boyd [off-list ref] writes:
Junio C Hamano wrote:
quoted
You are asking a wrong person. I am terrible at naming things; think
"rerere" ;-).
But I think custom-arghelp is much better than multargs. You are asking
"use this help for argument value _literally_", so another possibility
perhaps is PARSE_OPT_ARGHELP_LITERAL.
After all, there probably are many other valid reasons why you may not
want "s/.*/<&>/" blindly applied to your string. One reason may be
because the string describes multiple arguments, but I suspect that it is
not the only one. It is better to name the option after what it does,
than naming it after one sample reason why you might want to use that
option.
Ok. I think PARSE_OPT_LITERAL_ARGH might be good; until someone comes up
with a better one of course.
Well, 'ARGH' sounds a bit strange. I think I'd prefer ARGHELP. :-)
--
Jakub Narebski
Poland
ShadeHawk on #git
Heya,
On Tue, May 19, 2009 at 00:52, Jakub Narebski [off-list ref] wrote:
Well, 'ARGH' sounds a bit strange. I think I'd prefer ARGHELP. :-)
Yarr, it be reminding me of a patch from ye ol' mentor summit!
--
Cheers,
Sverre Rabbelier