Thread (15 messages) flat view 15 messages, 3 authors, 2016-06-15

Re: [EGIT PATCH 02/10] Rename the objectsUrl in the nested HttpObjectDB to

From: Robin Rosenberg <hidden>
Date: 2016-06-15 22:46:24

måndag 16 mars 2009 21:25:13 skrev "Shawn O. Pearce" [off-list ref]:
Robin Rosenberg [off-list ref] wrote:
quoted
It is used for looking at alternate objects, so name it such
No SOB?

But I disagree with this name change.  Its pointing at the
objects directory of a repository.  It may also be used to
point at an alternate when opening an alternate, in which
case it points at the alternate's objects directory.

IMHO, objectsUrl is the right name for this.
Ok, I missed the real reason in the comment. It is name hiding. objectsUrl
is the name of another variable in the outer scope.

-- robin
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help