Re: [EGIT PATCH 02/10] Rename the objectsUrl in the nested HttpObjectDB to
From: Shawn O. Pearce <hidden>
Date: 2016-06-15 22:46:24
Robin Rosenberg [off-list ref] wrote:
It is used for looking at alternate objects, so name it such
No SOB? But I disagree with this name change. Its pointing at the objects directory of a repository. It may also be used to point at an alternate when opening an alternate, in which case it points at the alternate's objects directory. IMHO, objectsUrl is the right name for this.
quoted hunk ↗ jump to hunk
--- .../org/spearce/jgit/transport/TransportHttp.java | 14 +++++++------- 1 files changed, 7 insertions(+), 7 deletions(-)diff --git a/org.spearce.jgit/src/org/spearce/jgit/transport/TransportHttp.java b/org.spearce.jgit/src/org/spearce/jgit/transport/TransportHttp.java index fe4a437..38d26b3 100644 --- a/org.spearce.jgit/src/org/spearce/jgit/transport/TransportHttp.java +++ b/org.spearce.jgit/src/org/spearce/jgit/transport/TransportHttp.java@@ -112,15 +112,15 @@ public void close() { } class HttpObjectDB extends WalkRemoteObjectDatabase { - private final URL objectsUrl; + private final URL alternateObjectsUrl;
-- Shawn.