Thread (6 messages) flat view 6 messages, 3 authors, 2016-06-15

Re: [PATCH v3] for-each-ref: `:short` format for `refname`

From: Bert Wesarg <hidden>
Date: 2016-06-15 22:45:17

Possibly related (same subject, not in this thread)

On Wed, Sep 3, 2008 at 18:33, Bert Wesarg [off-list ref] wrote:
On Wed, Sep 3, 2008 at 17:18, Shawn O. Pearce [off-list ref] wrote:
quoted
Bert Wesarg [off-list ref] wrote:
quoted
Try to shorten the refname to a non-ambiguous name.

Changes in v3:
 * don't compare sha1's, its ambiguous if the short name
   resovles to more than one ref
 * use xstrdup()
 * use indexes for the loops to clarify backward/forward
   direction


Signed-off-by: Bert Wesarg <redacted>
Cc: git@vger.kernel.org
Cc: szeder@ira.uka.de
Cc: Shawn O. Pearce <redacted>
---
Looks good.  But the commit messages shouldn't have the "Changes
in v3" section or probably the "Cc:" lines.  The changes in v3
part usually goes below the ---.
Ok, but shouldn't git format-patch detect that there is already a ---
in the commit message, or is it illegal to have more than one ---?

And while we are at it, shouldn't git format-patch detect, that there
is already a [*PATCH*]-prefix in the first line of the commit?
Ok, I was too fast, -k is obviously the right option for this.
I always need to edit these two things after format-patch.

Bert
quoted
--
Shawn.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help