Thread (6 messages) flat view 6 messages, 3 authors, 2016-06-15

Re: [PATCH v3] for-each-ref: `:short` format for `refname`

From: Shawn O. Pearce <hidden>
Date: 2016-06-15 22:45:17

Possibly related (same subject, not in this thread)

Bert Wesarg [off-list ref] wrote:
Try to shorten the refname to a non-ambiguous name.

Changes in v3:
 * don't compare sha1's, its ambiguous if the short name
   resovles to more than one ref
 * use xstrdup()
 * use indexes for the loops to clarify backward/forward
   direction


Signed-off-by: Bert Wesarg <redacted>
Cc: git@vger.kernel.org
Cc: szeder@ira.uka.de
Cc: Shawn O. Pearce <redacted>
---
Looks good.  But the commit messages shouldn't have the "Changes
in v3" section or probably the "Cc:" lines.  The changes in v3
part usually goes below the ---.

I don't usually work on for-each-ref, but I'll toss an ack in anyway:

Acked-by: Shawn O. Pearce <redacted>

-- 
Shawn.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help