Johannes Schindelin a écrit :
quoted
quoted
+ OPT_BOOLEAN(0, "bare", &bare, "set up a bare repo"),
s/set up/setup/
No. "setup" is a noun.
Right, sorry.
We rely on shared_repository == 0 for non-shared repositories _almost
everywhere_.
I think we rely on the fact that PERM_UMASK == 0 and not on the value
of shared_repository. Not the same thing.
That said, perhaps you are right: it is harmless.
quoted
quoted
+ OPT_BIT('q', "quiet", &flags, "be quiet", INIT_DB_QUIET),
OPT__QUIET(&quiet),
if (quiet)
flags |= INIT_DB_QUIET;
to use the same quiet option everywhere?
Why? Doesn't make it more readable, I think. I'd rather have 3 lines
less.
Hum.
Olivier.