Re: [PATCH v3 1/4] config.c: Add git_config_bool_or_int to handle bool/int variable
From: Junio C Hamano <hidden>
Date: 2016-06-15 22:44:28
Subsystem:
the rest · Maintainer:
Linus Torvalds
Ping Yin [off-list ref] writes:
quoted hunk ↗ jump to hunk
With git_config_bool_or_int, the caller can differentiate boolean true and integer 1 etc. Signed-off-by: Ping Yin <redacted> --- config.c | 15 +++++++++++++++ 1 files changed, 15 insertions(+), 0 deletions(-)diff --git a/config.c b/config.c index 0624494..e614456 100644 --- a/config.c +++ b/config.c@@ -316,6 +316,21 @@ int git_config_bool(const char *name, const char *value) return git_config_int(name, value) != 0; } +int git_config_bool_or_int(const char *name, const char *value, int *is_bool) +{ + *is_bool = 1; + if (!value) + return 1; + if (!*value) + return 0; + if (!strcasecmp(value, "true") || !strcasecmp(value, "yes")) + return 1; + if (!strcasecmp(value, "false") || !strcasecmp(value, "no")) + return 0; + *is_bool = 0; + return git_config_int(name, value); +} +
I expected git_config_bool() to be implemented in terms of this new function to avoid code duplication if we were actually going to do this. You also need an external declaration in a header file for its users. --- cache.h | 1 + config.c | 10 +++++++++- 2 files changed, 10 insertions(+), 1 deletions(-)
diff --git a/cache.h b/cache.h
index 2a1e7ec..50b28fa 100644
--- a/cache.h
+++ b/cache.h@@ -692,6 +692,7 @@ extern int git_parse_long(const char *, long *); extern int git_parse_ulong(const char *, unsigned long *); extern int git_config_int(const char *, const char *); extern unsigned long git_config_ulong(const char *, const char *); +extern int git_config_bool_or_int(const char *, const char *, int *); extern int git_config_bool(const char *, const char *); extern int git_config_string(const char **, const char *, const char *); extern int git_config_set(const char *, const char *);
diff --git a/config.c b/config.c
index 0624494..5ea18ef 100644
--- a/config.c
+++ b/config.c@@ -303,8 +303,9 @@ unsigned long git_config_ulong(const char *name, const char *value) return ret; } -int git_config_bool(const char *name, const char *value) +int git_config_bool_or_int(const char *name, const char *value, int *is_bool) { + *is_bool = 1; if (!value) return 1; if (!*value)
@@ -313,9 +314,16 @@ int git_config_bool(const char *name, const char *value) return 1; if (!strcasecmp(value, "false") || !strcasecmp(value, "no")) return 0; + *is_bool = 0; return git_config_int(name, value) != 0; } +int git_config_bool(const char *name, const char *value) +{ + int discard; + return git_config_bool_or_int(name, value, &discard); +} + int git_config_string(const char **dest, const char *var, const char *value) { if (!value)