On Tue, Sep 25, 2007 at 10:38:16AM +0000, Johannes Schindelin wrote:
Hi,
On Tue, 25 Sep 2007, Pierre Habouzit wrote:
quoted
--- a/cache-tree.c
+++ b/cache-tree.c
@@ -369,10 +369,8 @@ int cache_tree_update(struct cache_tree *it,
return 0;
}
-static void write_one(struct cache_tree *it,
- char *path,
- int pathlen,
- struct strbuf *buffer)
+static void write_one(struct strbuf *buffer, struct cache_tree *it,
+ const char *path, int pathlen)
I don't know... is this really needed? In some other projects, the coding
standard prefers the parameters in "in"..."out" order.
Well, this is thought in an OO way, buffer would be the "this". This
method could be named strbuf_addtree(...) hence I felt that having the
buffer as a first argument to be right.
But I don't care that much about that.
--
·O· Pierre Habouzit
··O madcoder@debian.org
OOO http://www.madism.org