Thread (6 messages) flat view 6 messages, 4 authors, 2016-06-15

Re: [PATCH 2/3] archive: specfile support (--pretty=format: in archive files)

From: René Scharfe <hidden>
Date: 2016-06-15 22:43:33

Possibly related (same subject, not in this thread)

Johannes Schindelin schrieb:
Hi,

On Tue, 4 Sep 2007, Andreas Ericsson wrote:
quoted
Junio C Hamano wrote:
quoted
René Scharfe [off-list ref] writes:
quoted
The attribute is useful for creating auto-updating specfiles.  It is 
limited by the underlying function format_commit_message(), though. 
E.g. currently there is no placeholder for git-describe like output, 
and expanded specfiles can't contain NUL bytes.  That can be fixed 
in format_commit_message() later and will then benefit users of 
git-log, too.
Interesting. I however wonder if "specfile" is a good name for this 
attribute, although I admit I do not think of anything better offhand.
"releasefile", perhaps?
Maybe we should not so much name it by purpose, but by function.  How 
about "substformat" for the attribute name, and replacing any 
$Format:blablub$ inside those files with something a la 
--pretty=format:blablub?
I like the $Format:...$ notation.  How about naming the attribute
"template", as that's what a thus marked file is?

René
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help