Thread (9 messages) flat view 9 messages, 3 authors, 2016-11-07

Re: [PATCH 3/3] vhost: update comments

From: Yuanhan Liu <hidden>
Date: 2016-11-04 14:14:26

On Fri, Nov 04, 2016 at 01:28:45PM +0000, Mcnamara, John wrote:
quoted
-----Original Message-----
From: Yuanhan Liu [mailto:yuanhan.liu@linux.intel.com]
Sent: Wednesday, November 2, 2016 3:15 AM
To: dev@dpdk.org
Cc: Mcnamara, John <redacted>; Yuanhan Liu
[off-list ref]
Subject: [PATCH 3/3] vhost: update comments

vhost-cuse is removed, update corresponding comments that are still
referencing it.

Signed-off-by: Yuanhan Liu <redacted>

...

 /*
- * Backend-specific cleanup. Defined by vhost-cuse and vhost-user.
+ * Backend-specific cleanup.
+ *
+ * TODO: fix it; we have one backend now
  */
 void vhost_backend_cleanup(struct virtio_net *dev);
In general it is not a good idea to leave TODOs/Fixmes around unless they
that a better explanation of why they are there.
Agreed.

In this case, if you look at the delete line, you will find we have such
function implemented both in vhost-user and vhost-cuse. Now we get one
only. So, we may could just rename it to vhost_user_cleanup(). Or even,
remove it completely by doing some small refactors.

It's obvious that we need do that in another patch. Thus, the TODO is
been added.

	--yliu
Apart from that:


Acked-by: John McNamara <redacted>
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help