Re: [B.A.T.M.A.N.] [PATCHv2 1/4] batman-adv: substitute tt_poss_change with a per-tt_entry flag
flat view
From: Marek Lindner <hidden>
Date: 2012-10-01 08:24:53
On Monday, September 24, 2012 04:38:34 Antonio Quartulli wrote:
tt_poss_change is a node-wide flag which tells whether the node is in a roaming state (a client recently moved to/away from it) in order to let it apply special re-routing rules. However this flag does not give a clear idea of the current state because it is not possible to understand which client is actually involved in the roaming. For this reason a better approach has been chosen: instead of using a node-wide variable, the roaming state is now given by a per-tt_entry ROAM flag which, in case of packet coming through the node, tells the node whether the real destination is in roaming state or not. With this flag change, batadv_check_unicast_ttvn() has also been rearranged in order to better fit the new re-routing logic and to be much more readable. Signed-off-by: Antonio Quartulli <redacted> --- originator.c | 1 - routing.c | 156 +++++++++++++++++++++++++++++++++++----------------- soft-interface.c | 1 - translation-table.c | 43 ++++++++++----- translation-table.h | 2 + types.h | 8 --- 6 files changed, 138 insertions(+), 73 deletions(-)
Applied in revision 3fbd7ac. Thanks, Marek