Re: [PATCH net-next v12 04/14] mm: page_frag: add '_va' suffix to page_frag API
From: Alexander Duyck <hidden>
Date: 2024-08-02 17:01:18
Also in:
bpf, intel-wired-lan, kvm, linux-mediatek, linux-mm, linux-nfs, linux-nvme, lkml, netdev
On Fri, Aug 2, 2024 at 3:05 AM Yunsheng Lin [off-list ref] wrote:
On 2024/8/1 23:21, Alexander Duyck wrote:quoted
On Thu, Aug 1, 2024 at 6:01 AM Yunsheng Lin [off-list ref] wrote:quoted
On 2024/8/1 2:13, Alexander Duyck wrote:quoted
On Wed, Jul 31, 2024 at 5:50 AM Yunsheng Lin [off-list ref] wrote:quoted
Currently the page_frag API is returning 'virtual address' or 'va' when allocing and expecting 'virtual address' or 'va' as input when freeing. As we are about to support new use cases that the caller need to deal with 'struct page' or need to deal with both 'va' and 'struct page'. In order to differentiate the API handling between 'va' and 'struct page', add '_va' suffix to the corresponding API mirroring the page_pool_alloc_va() API of the page_pool. So that callers expecting to deal with va, page or both va and page may call page_frag_alloc_va*, page_frag_alloc_pg*, or page_frag_alloc* API accordingly. CC: Alexander Duyck <redacted> Signed-off-by: Yunsheng Lin <redacted> Reviewed-by: Subbaraya Sundeep <sbhatta@marvell.com>I am naking this patch. It is a pointless rename that is just going to obfuscate the git history for these callers.I responded to your above similar comment in v2, and then responded more detailedly in v11, both got not direct responding, it would be good to have more concrete feedback here instead of abstract argument. https://lore.kernel.org/all/74e7259a-c462-e3c1-73ac-8e3f49fb80b8@huawei.com/ (local) https://lore.kernel.org/all/11187fe4-9419-4341-97b5-6dad7583b5b6@huawei.com/ (local)I will make this much more understandable. This patch is one of the ones that will permanently block this set in my opinion. As such I will never ack this patch as I see no benefit to it. Arguing with me on this is moot as you aren't going to change my mind, and I don't have all day to argue back and forth with you on every single patch.Let's move on to more specific technical discussion then.quoted
As far as your API extension and naming maybe you should look like something like bio_vec and borrow the naming from that since that is essentially what you are passing back and forth is essentially that instead of a page frag which is normally a virtual address.I thought about adding something like bio_vec before, but I am not sure what you have in mind is somthing like I considered before? Let's say that we reuse bio_vec like something below for the new APIs: struct bio_vec { struct page *bv_page; void *va; unsigned int bv_len; unsigned int bv_offset; };
I wasn't suggesting changing the bio_vec. I was suggesting that be what you pass as a pointer reference instead of the offset. Basically your use case is mostly just for populating bio_vec style structures anyway.
It seems we have the below options for the new API:
option 1, it seems like a better option from API naming point of view, but
it needs to return a bio_vec pointer to the caller, it seems we need to have
extra space for the pointer, I am not sure how we can avoid the memory waste
for sk_page_frag() case in patch 12:
struct bio_vec *page_frag_alloc_bio(struct page_frag_cache *nc,
unsigned int fragsz, gfp_t gfp_mask);
option 2, it need both the caller and callee to have a its own local space
for 'struct bio_vec ', I am not sure if passing the content instead of
the pointer of a struct through the function returning is the common pattern
and if it has any performance impact yet:
struct bio_vec page_frag_alloc_bio(struct page_frag_cache *nc,
unsigned int fragsz, gfp_t gfp_mask);
option 3, the caller passes the pointer of 'struct bio_vec ' to the callee,
and page_frag_alloc_bio() fills in the data, I am not sure what is the point
of indirect using 'struct bio_vec ' instead of passing 'va' & 'fragsz' &
'offset' through pointers directly:
bool page_frag_alloc_bio(struct page_frag_cache *nc,
unsigned int fragsz, gfp_t gfp_mask, struct bio_vec *bio);
If one of the above option is something in your mind? Yes, please be more specific
about which one is the prefer option, and why it is the prefer option than the one
introduced in this patchset?
If no, please be more specific what that is in your mind?Option 3 is more or less what I had in mind. Basically you would return an int to indicate any errors and you would be populating a bio_vec during your allocation. In addition you would use the bio_vec as a tracker of the actual fragsz so when you commit you are committing with the fragsz as it was determined at the time of putting the bio_vec together so you can theoretically catch things like if the underlying offset had somehow changed from the time you setup the allocation. It would fit well into your probe routines since they are all essentially passing the page, offset, and fragsz throughout the code.