Thread (1 message) 1 message, 1 author, 2021-11-29

Re: [PATCH v2] fuse: rename some files and clean up Makefile

From: Vivek Goyal <vgoyal@redhat.com>
Date: 2021-11-29 13:35:51
Also in: linux-fsdevel, lkml

On Mon, Nov 29, 2021 at 09:27:17PM +0800, Tiezhu Yang wrote:
On 11/29/2021 06:19 PM, Stefan Hajnoczi wrote:
quoted
On Sat, Nov 27, 2021 at 06:13:22PM +0800, Tiezhu Yang wrote:
quoted
No need to generate virtio_fs.o first and then link to virtiofs.o, just
rename virtio_fs.c to virtiofs.c and remove "virtiofs-y := virtio_fs.o"
in Makefile, also update MAINTAINERS. Additionally, rename the private
header file fuse_i.h to fuse.h, like ext4.h in fs/ext4, xfs.h in fs/xfs
and f2fs.h in fs/f2fs.
There are two separate changes in this patch (virtio_fs.c -> virtiofs.c
and fuse_i.h -> fuse.h). A patch series with two patches would be easier
to review and cleaner to backport.

I'm happy with renaming virtio_fs.c to virtiofs.c:

Reviewed-by: Stefan Hajnoczi <stefanha@redhat.com>
Hi Stefan and Miklos,

Thanks for your reply, what should I do now?

(1) split this patch into two separate patches to send v3;
(2) just ignore this patch because
"This will make backport of bugfixes harder for no good reason."
said by Miklos.
I agree with Miklos that there does not seem to be a very strong reason
to rename. It probably falls in the category of nice to have cleanup. But
it will also make backports harder. So I also like the idea of not making
this change.

Vivek

_______________________________________________
Virtualization mailing list
Virtualization@lists.linux-foundation.org
https://lists.linuxfoundation.org/mailman/listinfo/virtualization
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help