Thread (2 messages) 2 messages, 2 authors, 2021-11-22

Re: [PATCH V5 07/10] io_uring: switch to kernel_worker

From: Jens Axboe <axboe@kernel.dk>
Date: 2021-11-22 14:20:10
Also in: lkml

On 11/22/21 3:02 AM, Christian Brauner wrote:
On Sun, Nov 21, 2021 at 11:17:11AM -0700, Jens Axboe wrote:
quoted
On 11/21/21 10:49 AM, Mike Christie wrote:
quoted
Convert io_uring and io-wq to use kernel_worker.
I don't like the kernel_worker name, that implies it's always giving you
a kernel thread or kthread. That's not the io_uring use case, it's
really just a thread off the original task that just happens to never
exit to userspace.

Can we do a better name? At least io_thread doesn't imply that.
Yeah, I had thought about that as well and at first had kernel_uworker()
locally but wasn't convinced. Maybe we should just make it
create_user_worker()?
That's better, or maybe even create_user_inkernel_thread() or something?
Pretty long, though... I'd be fine with create_user_worker().

-- 
Jens Axboe

_______________________________________________
Virtualization mailing list
Virtualization@lists.linux-foundation.org
https://lists.linuxfoundation.org/mailman/listinfo/virtualization
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help