On Tue, Oct 05, 2021 at 06:42:43AM -0400, Michael S. Tsirkin wrote:
Stefan also pointed out this duplicates the logic from
if (blksize < 512 || blksize > PAGE_SIZE || !is_power_of_2(blksize))
return -EINVAL;
and a bunch of other places.
Would it be acceptable for blk layer to validate the input
instead of having each driver do it's own thing?
Maybe inside blk_queue_logical_block_size?
I'm pretty sure we want down that before. Let's just add a helper
just for that check for now as part of this series. Actually validating
in in blk_queue_logical_block_size seems like a good idea, but returning
errors from that has a long tail.
_______________________________________________
Virtualization mailing list
Virtualization@lists.linux-foundation.org
https://lists.linuxfoundation.org/mailman/listinfo/virtualization