RE: [PATCH v3] crypto: add virtio-crypto driver
From: "Gonglei (Arei)" <arei.gonglei@huawei.com>
Date: 2016-11-29 09:31:32
On Tue, Nov 29, 2016 at 08:22:58AM +0000, Gonglei (Arei) wrote:quoted
Hi,quoted
quoted
quoted
quoted
+source "drivers/crypto/virtio/Kconfig" + endif # CRYPTO_HWdiff --git a/drivers/crypto/Makefile b/drivers/crypto/Makefile index ad7250f..bc53cb8 100644 --- a/drivers/crypto/Makefile +++ b/drivers/crypto/Makefile@@ -32,3 +32,4 @@ obj-$(CONFIG_CRYPTO_DEV_VMX) += vmx/ obj-$(CONFIG_CRYPTO_DEV_SUN4I_SS) += sunxi-ss/ obj-$(CONFIG_CRYPTO_DEV_ROCKCHIP) += rockchip/ obj-$(CONFIG_CRYPTO_DEV_CHELSIO) += chelsio/ +obj-$(CONFIG_CRYPTO_DEV_VIRTIO) += virtio/diff --git a/drivers/crypto/virtio/Kconfig b/drivers/crypto/virtio/Kconfig new file mode 100644 index 0000000..ceae88c --- /dev/null +++ b/drivers/crypto/virtio/Kconfig@@ -0,0 +1,10 @@ +config CRYPTO_DEV_VIRTIO + tristate "VirtIO crypto driver" + depends on VIRTIO + select CRYPTO_AEAD + select CRYPTO_AUTHENC + select CRYPTO_BLKCIPHERInconsistent tab vs space whitespace usage.Will fix.quoted
quoted
quoted
+ default m + help + This driver provides support for virtio crypto device. If you + choose 'M' here, this module will be called virtio-crypto.All the other virtio drivers use underscore ('_') instead of hyphen ('-').Except virtio-rng.quoted
I suggest calling it virtio_crypto for consistency.OK, I will change the Makefile to fix it.I tried to do this, but I failed. Because virtio_crypto.ko consists of more than one source file which include tree files currently, and virtio_crypto.ko matchs the name of virtio_crypto.c. That's different with all other virtio drivers.Can you rename virtio_crypto.c to virtio_crypto_core.c?
I'm fine with virtio_crypto_core.c. What about you? Michael? Regards, -Gonglei
I'm not very familiar with the kernel Makefile infrastructure so maybe there's a better way of doing it. Stefan