On Thu, 22 Aug 2013 22:47:28 +0100
Zoltan Kiss [off-list ref] wrote:
quoted hunk
/*
* Used to do a quick range check in swiotlb_tbl_unmap_single and
* swiotlb_tbl_sync_single_*, to see if the memory was in fact allocated by this
@@ -358,6 +362,9 @@ dma_addr_t xen_swiotlb_map_page(struct device *dev, struct page *page,
/*
* Oh well, have to allocate and map a bounce buffer.
*/
+
+ trace_bounced(dev, dev_addr, size, swiotlb_force);
Please use a more specific name. "bounce" is too generic. I know
tracepoints are grouped by systems, but its easier for tools to just
state a tracepoint name than the system:event pair.
trace_xen_bounced()
or
trace_swiotlb_bounced()
Something other than just "bounced".
Thanks!
-- Steve
quoted hunk
+
map = swiotlb_tbl_map_single(dev, start_dma_addr, phys, size, dir);
if (map == SWIOTLB_MAP_ERROR)
return DMA_ERROR_CODE;