On (Fri) 11 Nov 2011 [14:57:20], Rusty Russell wrote:
On Tue, 08 Nov 2011 13:44:58 -0800, Miche Baker-Harvey [off-list ref] wrote:
quoted
Some modifications of vtermno were not done under the spinlock.
Moved assignment from vtermno and increment of vtermno together,
putting both under the spinlock. Revert vtermno on failure.
Signed-off-by: Miche Baker-Harvey <redacted>
Does it matter? It's normal not to lock in a function called
"init_XXX", since it's not exposed yet.
Or is it?
Slight misnomer, I suppose.
We do this init_console_port() as part of add_port() if the port is a
console port. Should it be named 'mark_console_port()'? Dunno,
doesn't sound like the right name. init fits closest.
Amit