On Fri, 28 Oct 2011, KY Srinivasan wrote:
quoted
quoted
quoted
quoted
obj-$(CONFIG_HID_WACOM) += hid-wacom.o
obj-$(CONFIG_HID_WALTOP) += hid-waltop.o
obj-$(CONFIG_HID_WIIMOTE) += hid-wiimote.o
+obj-$(CONFIG_HYPERV_MOUSE) += hv_mouse.o
I'd prefer a bit to follow the current naming of the drivers in
drivers/hid directory ... all the device-specific (vendor-specific)
drivers currently are called hid-<vendor> or similar.
We could talk about changing this naming scheme, but before we reach any
conclusion on this, I'd prefer this to stay for all drivers if possible.
Do you want the driver module to conform to the naming scheme you have?
Greg, in the past has resisted changing driver names, but I have no objection
to conforming to the naming convention you have.
I recommend following the proper naming scheme. As this driver is
auto-loaded when the virtual hardware is seen, the name really doesn't
matter at all.
So, how about 'hid-hyperv' or 'hid-hv'?
I will go with hid-hv if there are no objections.
OK by me, thanks.
--
Jiri Kosina
SUSE Labs