RE: [PATCH 3/6] Staging: hv: Cleanup hyperv_device variable names
From: KY Srinivasan <kys@microsoft.com>
Date: 2011-02-26 17:13:45
Also in:
lkml
-----Original Message----- From: Dan Carpenter [mailto:error27@gmail.com] Sent: Friday, February 25, 2011 10:33 PM To: KY Srinivasan Cc: gregkh@suse.de; linux-kernel@vger.kernel.org; devel@linuxdriverproject.org; virtualization@lists.osdl.org Subject: Re: [PATCH 3/6] Staging: hv: Cleanup hyperv_device variable names On Fri, Feb 25, 2011 at 06:06:32PM -0800, K. Y. Srinivasan wrote:quoted
Cleanup the names of variables that refer to the hyperv_device abstraction.I have a script I run on rename patches. For this patch the command would be: rename_rev.pl -nc -e 's/device_ctx/device_obj/g' -e 's/\bdev_ctx/dev/g' It show one variable was missed in storvsc_probe().quoted
memset(host_device_ctx, 0, sizeof(struct host_device_context)); host_device_ctx->port = host->host_no; - host_device_ctx->device_ctx = device_obj; + host_device_ctx->device_obj = device_obj; host_device_ctx->request_pool = kmem_cache_create(dev_name(&device_obj- device),@@ -271,7 +271,7 @@ static int storvsc_probe(struct device *device) return -1; } - /* host_device_ctx->port = device_info.PortNumber; */ + /* host_hyperv_dev->port = device_info.PortNumber; */ host_device_ctx->path = device_info.path_id; host_device_ctx->target = device_info.target_id;All the other host_device_ctx variables were renamed to host_device_obj.
host_device_ctx is a scsi abstraction built on top of the hyperv_device abstraction. My goal was not to change the names of higher level scsi abstractions. Regards, K. Y
regards, dan carpenter